منتديات ناصر الكميلى
السلام عليكم ورحمة الله وبركاته .. نتمنى أن تكون بصحة جيدة .


سبحان الله وبحمده ، سبحان الله العظيم
 
الرئيسيةالبوابةس .و .جبحـثالتسجيلدخول

اللهم أنت ربى لا إله إلا أنت ، خلقتنى وأنا عبدك ، وأنا على عهدك ووعدك ما استطعت ، أعوذ بك من شر ما صنعت ، أبوء لك بنعمتك علىَ وأبوء بذنبى ، فاغفر لى فإنه لا يغفر الذنوب إلا أنت .


شاطر | 
 

 الميكروتيك من الألف إلى الياء

استعرض الموضوع السابق استعرض الموضوع التالي اذهب الى الأسفل 
كاتب الموضوعرسالة
master
Admin
Admin
avatar

عدد المساهمات : 144
تاريخ التسجيل : 27/02/2014
العمر : 36
الموقع : الأمة الإسلامية

مُساهمةموضوع: الميكروتيك من الألف إلى الياء   الخميس 06 مارس 2014, 10:53 am






[size=24][size=48]السلام عليكم ورحمة [size=48]الله وبركاته[/size][/size][/size]
 

[size=18]الموضوع عبارة عن شرح وتجميع لأهم مواضيع الميكروتيك على الفيرشوال ماشين
هنبدأ فى اول فيديو شرح البرنامج الى مشروح عليه كل حاجة الى هوا الفيرشوال ماشين
وهوا دا[size=24]الأداة Tool الى هنطبق عليها كل حاجة

البرنامج ممكن تستبه على وندوز إكس بى عادى خالص او وندوز سيرفر
وبعد كدة تستب على البرنامج نفسه الميكروتيك وتتعامل مع الميكروتيك باحترافية كما لم يسبق لك من قبل
طيب ايه المواصفات المطلوبة
[/size]
[/size]

[size=18]اى كيسة بنتيوم فور اوريجنال او غير اوريجنال هتفى بالغرض
تكون فى حدود رامات 512
ويستحسن واحد جيجا
وبروسيسور 2.4 او 2.6 او 3.0
[size=32]وكرتين لان فقط واحد للإكسترنال وواحد للإنترنال [size=48]فقط
[/size][/size][/size]

[size=24]******************** [/size]

[size=18]أولا لنك البرنامج
برنامج vmware وللعلم الفرجن الى ينفع عليه الشرح كله فرجن 6.0
[size=24]part 1

Part 2

********************************
وقبل تنزيل ملفات الشرح نرجوا من الأخوة كل واحد يلغى الكودك الى عنده وينزل الكودك دا احدث كودك موجود تقريبا لو صادفه مشكلة فى تشغيل الملفات الفيديو مع العلم ان الملفات من النوع AVI
برنامج الكودك اسمه
K-Lite Mega Codec Pack 5.9
[/size]
[/size]


[size=24]**************************
[/size]
[size=18][size=24]الملف الأول: عبارة عن تعريف عام بالفيرشوال ماشين ومفاهيم اساسية فيه وكيفية استخدامه[/size][/size][size=18]لتحميل الملف الأول من[/size][size=24] هنا[/size]

[size=24]**********************************[/size]

[size=18][size=24]الملف الثانى : عبارة عن تستيب الميكروتيك 2.9.27 وإدخال الإنترنت داخل الميكروتيك من الروتر فقط بدون إخارج النت للمستخدمين
[/size]
[/size]

[size=18]لتحميل الملف لثانى من[/size]هنا


[size=18]ولتحميل نسخة الميكروتيك 2.9.27 من هنا[/size]
[size=24]*********************************[/size]
[size=18][size=24]الملف الثالث : كيفية تستيب وندوز إكس بى على الفيرشوال ماشين وأخذ الإنترنت من الميكروتيك الى وندوز إكس بى الى متستب برده على الفيرشوال ماشين[/size][/size]لتحميل الملف الثالث من[size=24]هنا[/size]
[size=24]********************************[/size]

[size=18][size=24]الملف الرابع : كيفية إخراج الإنترنت باستخدام HotSpot
[/size]
[/size]

[size=18]وتعلم DHCP Server[/size]

وتعلم إلغاء وظيفية قطع النت لبرنامج النت كت وغيره من البرامج

ولكن إلغاء إظهار الماكات على النت كت وغيره سيتم شرحها فى آخر ملف وهوا البرودباند هنا سيتم شرح كيفية إلغاء
[size=18]وظيفة قطع النت عن المستخدمين فقط ولكن الماكات بتظهر لسة[/size]

لتحميل الملف الرابع من

[size=18][size=32]هنا أو من [size=32]هنا[/size]
ملحوظة مهمة
انا فى الملف رقم 4 فى آخر دقيقة قلت ان الماك الى بيتحط فى خانة
IP Binding
وفى الهوت سبوت لو فى اكتر من ريبيتر واخدين من بعض بتحط الماك الخاص بأخر ريبيتر الى العميل بيستلم منه النت الى هوا أخر ريبيتر مباشرة للعميل والكلام خرج منى خطأ على سبيل السهو
والصحيح انتا بتحط الماك بتاع أول ريبيتر من جهة السيرفر مش من جهة العميل لأن كل الى ورا أول ريبيتر بيظهر للسيرفر بماكه يعنى لو وراه ريبيتر و 2 و 3 و 4 كلهم بيظهروا بماك اول ريبيتر للسيرفر
لكن الماك فى ال DHCP زى منا قلت فى الليسس الماك بيتحط بتاع الكمبيوتر نفسه سواء كارت لان او ويرلس
طبعا الريبيتر المقصود بيه فى وسط الكلام اما
Universal Repeater
WDS Repeater
أما ظهور الماك على الهوت سبوت فالمودز الأتية يظهر فيها العميل بماك الكمبيوتر الشخصى على الهوت سبوت
Repeater
Bridge
Client With WDS
WDS Repeater

والمودز الأتية يظهر العميل بماك الاكسس
Client
Universal Repeater

[/size]
[/size]

[size=24]*****************************[/size]

[size=18][size=24]الملف الخامس :نتعلم فيه الآن كيفية إخراج الإنترنت إلى الشبكة الفعلية بدلا من إكس بى على فيرشوال ماشين فقط
[/size]
[/size]

[size=18]أى سنتعلم فيه كيفية إخراج الإنترنت بصورة فعلية للمستخدمين على سويتش والسويتش يوزع النت للمستخدمين[/size]

لتحميل الملف الخامس من [size=24]هنا
****************************** [/size]
الملف السادس : كيفية ضم عدد من الخطوط يصل إلى 8 خطوط إنترنت على الفرجن 2.9.27 بطريقة nth
[size=18]على كرتين لان فقط فى الكيسة واحد إكسترنال يسحب النت وواحد إنترنال يوزع النت
كرتين فقط حقيقيين فى الكيسة
[/size]

الطريقة

بالنسبة للإكسترنال هتحط الروترات الى عاوز تضمها كلها على سويتش والسويتش يطلع منه سلك واحد فقط لكارت الإكسترنال الموجود فى الكيسة والإنترنال هيطلع منه سلك لسويتش رقم 2 والسويتش رقم 2 يوزع النت للناس
[size=18]والشرح فى ملف الفيديو
ثم انظر فى شرح الملف رقم عشرة لتعرف كيفية حل مشكلة الهوت سبوت على نفس السيرفر
بحيث تضم الخطوط وتخرج نت بالهوت سبوت من نفس الكيسة
[/size]

لتحميل الملف السادس من

[size=24]هنا
ولتحميل الكود من هنا
ولمعرفة الفرق بين التحميل ببرنامج دونلوود منجر وبين التحميل العادى بعد دمج السرعات يستحسن تنزيل هذا الملف من [size=24]هنا
[/size][/size]

[size=24]*****************************[/size]

[size=18][size=24]الملف السابع : كيفية تستيب النسخة 3.2 على الفيرشوال ماشين وتكريكها وعمل تحديث لها حتى الفرجن 3.3 على ليفل أربعة Level 4
[/size]
[/size]

[size=18]ومن بركة العلم نسبته إلى أهله ففكرة الشرح فى هذا الملف مستوحى من فكرة الأخ شيكوا له منا كل احترام وتقدير ولكن مشروح بتفصيل اكبر وفيديو[/size]

[size=18]لتحميل الملف السابع من هنا[/size]
[size=18]لنك النسخة 3.2 من هنا [/size]
[size=18]لنك ال ك ر ا ك من هنا [/size]
[size=18]ولنك النسخة 3.3 من هنا[/size]

[size=24]******************************[/size]

[size=18][size=24]الملف الثامن : استيراد أو عمل Import لمكنة جاهزة متستب عليها النسخة 3.3 متكركة جاهزة لحد ليفل أربعة فى خمس دقائق فقط
[/size]
[/size]

[size=18]وأظن دى تحل المشكلة للأخ الى كان بيقول انه عاوز يكرك من فلاشة وعاوز الكود أعتقد الطريقة دى أسهل
إنك تاخد المكنة متكركة فى خمس دقايق جاهزة وآسفين ليه على التأخير فى الموضوع بس زى منتا شايف الموضوع كبير أد ايه
[/size]

لتحميل الملف الثامن من

[size=24]هنا[/size]
[size=18]ودا لنك الهارد للنسخة 3.2 جاهز للإستيراد فى مكنة فيرشوال ماشين 6.0 من هنا[/size]
[size=18]ودا لنك الهارد للنسخة 3.3 جاهز للإستيراد فى مكنة فيرشوال ماشين 6.0 من هنا[/size]


[size=24]******************************************[/size]

[size=18][size=24]الملف التاسع:كيفية تفعيل الكاش على النسخة 3.3 واستخدامه
[/size]
[/size]

[size=18]واستخدام الكاش فلتر
وكيفية تحويل كاش النسخة 2.9.27 مثل النسخة 3.3 بالظبط فى الكاش فلتر
ومن بركة العلم نسبته إلى أهله ففكرة تحويل كاش النسخة 2.9.27 إلى مثل النسخة 3.3 من أفكار الأخ رائد جمعة صاحب العضوية raedjomaa
[/size]


[size=18]لتحميل الملف التاسع من هنا[/size]
شرح االإختيار Cache On Disk داخل إعدادات الكاش
والتطرق لبعض المفاهيم مثل
Physical Memory , Virtual Memory
وسرعات الهارد ديسك والرام والبروسيسور والتفاوت بينهم
[size=18]لتحميل الملف الثالث عشر من
[size=32]هنا
[/size][/size]

[size=24]******************************************[/size]
الملف العاشر : شرح ضم عدد يمكن أن يصل ل8 خطوط على الفرجن 3.3 بطريقة ال nth
بكرتين لان فعليين فقط واحد إكسترنال ياخد النت وواحد إنترنال يوزع النت للمستخدمين
بالنسبة للإكسترنال هتحط الروترات الى عاوز تضمها كلها على سويتش والسويتش يطلع منه سلك واحد فقط لكارت الإكسترنال الموجود فى الكيسة والإنترنال هيطلع منه سلك لسويتش رقم 2 والسويتش رقم 2 يوزع النت للناس
زى طريقة 2.9.27 بالظبط
الزيادة هنا عن هناك فى الشرح
حل مشكلة الهوت سبوت ان الناس مكانتش عارفة تخرج نت بالهوت سبوت من نفس السيرفر الى بتضم عليه فلازم
الناس كانت تحط سيرفر تانى للتوزيع بحيث يكون سيرفر ضم وسيرفر توزيع
احنا حلينا هنا المشكلة وتقدر توزع بالهوت سبوع من نفس السيرفر الى هتضم عليه

لتحميل الملف العاشر من

[size=24]هنا[/size]
[size=18]ولتحميل كود الضم من هنا[/size]

[size=24]*******************************
[/size]الملف الحادى عشر : تعلم كيفية الدمج بستخدام طريقة PCC التى تدعم Fail Over بحيث لو تم قطع الخدمة عن خط سيتم تحويل الترافيك الموجود بنسبة 100 فى المية على الخط الثانى

والطريقة تم شرحها لتتناسب مع وجود الهوت سبوت أو مع عدم وجوده ويجب تحميل ملف الفيديو أولا قبل تطبيق الكود لأن الكود بالوضع الإفتراضى لايعمل مع الهوت سبوت وتم الشرح داخل ملف الفيديو لجعله يدعم الهوت سبوت

لتحميل الملف الفيديو من هنا

[size=18][size=24]لتحميل الكود من هنا
[/size]
[/size]

[size=24]******************************* [/size]

[size=18][size=24]الملف الثانى عشر : تعلم كيفية إغلاق المواقع الإباحية عن طريق استخدام OpenDNS
[/size]
[/size]

[size=18]من الألف إلى الياء وكيفية تحديث رقم الإنترت الخاص بالديناميك وان اى بى بسهولة جدا بدون اسكربت ودون الجلوس كل فترة لتشغيل اداة تحديث الأى بى فقط دع كل شيء يعمل بصورة تلقائية بدلا عنك والطريقة تصلح مع جميع النسخ
2.9.27 3.2 3.3 4.6 أى نسخة تقدر تحدث رقم الإنترنت الخاص بيك
بسهولة وبصورة اوتوماتيك من غير متتعب وتقعد كل شوية تفتح اداة التحديث عشان تجيب الرقم الجديد
[/size]


ولمنع أى عميل من استخدام أى DNS آخر غير OpenDNS
لو استخدم الأرقام مانوالى بدلا عن DHCP
يرى استخدام هذا الكود مع نسخة المايكروتيك 3.3

/ip firewall filter
add action=accept chain=forward comment="Allow OpenDNS Traffic" disabled=no \
dst-address=208.67.222.222 dst-port=53 protocol=udp
add action=accept chain=forward comment="" disabled=no dst-address=\
208.67.220.220 dst-port=53 protocol=udp
add action=accept chain=forward comment="" disabled=no dst-address=\
208.67.222.222 dst-port=53 protocol=tcp
add action=accept chain=forward comment="" disabled=no dst-address=\
208.67.220.220 dst-port=53 protocol=tcp
add action=drop chain=forward comment="Drop Any other DNS" disabled=no \
dst-port=53 protocol=tcp
add action=drop chain=forward comment="Drop Any other DNS" disabled=no dst-port=53 protocol=udp
واستخدام هذا الكود مع النسخة 2.9.27

/ ip firewall filter
add chain=forward dst-address=208.67.222.222 protocol=tcp dst-port=53 \
action=accept comment="" disabled=no
add chain=forward dst-address=208.67.220.220 protocol=tcp dst-port=53 \
action=accept comment="" disabled=no
add chain=forward dst-address=208.67.222.222 protocol=udp dst-port=53 \
action=accept comment="" disabled=no
add chain=forward dst-address=208.67.220.220 protocol=udp dst-port=53 \
action=accept comment="" disabled=no
add chain=forward protocol=tcp dst-port=53 action=drop comment="" disabled=no
add chain=forward protocol=udp dst-port=53 action=drop comment="" disabled=no



وتعلم هنا ايضا كيف تغلق الكيسة مثلا ساعتين الصبح ترتاح فيهم وازااى الكيسة تشتغل تانى لوحدها بمعنى مثلا الكيسة كلها تطفى الساعة 6 صباحا وتريح 3 ساعات وتشتغل لوحدها تانى الساعة 9 صباحا

بصورة تلقائية يوميا بدون تدخل منك
[size=18]كله شغال فى دورة اوتوماتيك منتظمة جدا
وبدون سكربتات
وأنا اعنى الكيسة تريح يعنى الكيسة كلها هارد وير وسوفت وير مش سوفت وير فقط
وآسفين على التأخير على الأخ الى كان منتظر النقطة دى على حد تعبيره على أحر من الجمر
لكن زى منتا شايف الموضوع عامل ازاى تنسيقه لوحده عاوز يوم
لتحميل الملف الحادى عشر من
[/size]


[size=24]هنا [/size]
[size=18]ولتحميل برنامج Auto Shutdown
[/size]

[size=18]من هنا[/size]


[size=24]******************************[/size]

[size=18][size=24]الملف الثالث عشر : تعلم كيفة تشغيل البرودباند PPPoEباحترافية لم يسبق لها مثيل فى إخراج الإنترنت للمستخدمين والحفاظ على شبكتك من الإنهيار[/size][/size]

[size=18]كل الفكرة إنى بستخدم طريقة
Proxy ARP
بدلا من ال ARP
العادية والطريقة المشروحة هنا ألصق ماتكون بفكرة
Bridge
[/size]

طبعا انا مش هطول كتير فى نظام التشغيل البرودباند الرائع بل الأكثر من رائع الشرح داخل ملف الفيديو

لكن كل ماأنبه إليه إننا هنا فى البرودباند قدرنا نلغى وظيفتى النت كت وغيره من برامج السبوفنج
[size=18][size=24]الخاصية الأولى قطع النت عن المستخدمين وتم إلغاء هذه الخاصية بنجاح
الخاصية الثانية عدم ظهور ماكات اى عميل من العملاء فى النت كت او غيره من اى برنامج من برامج السبوفنج
وأظن كدة يبقى قضينا على كل مشاكل البرودكاست طيب واحد يقولى امال ايه الى هيظهر على النت كت لما افتحه هقولك بكل بساطة حمل الملف الفيديو وشوف بنفسك ايه الى بيظهر
وفى طبعا حاجة
معنى انك قضيت على البرودكاست للعملاء بينهم وبين بعض بالأيبيهات والماكات يبقى قضيت على معظم الفيروسات الى بتشتغل على الوتر دا وتر البرودكاست زى الفيرس الصينى وإخوانه من الفيروسات الأخرى
[/size]
[/size]


[size=18]لتحميل الملف الثانى عشر من[/size]
[size=32]هنا[/size]

[size=24]*****************************
[/size]
الملف الرابع عشر: كيفية وضع الميكروتيك فى وندوز ستارت اب Start UPحتى يعمل مع بداية تشغيل الكيسة كل مرة
[size=18]ثم تعلم كيفية الحفاظ على الميكروتيك من الإنهيار حيث ان الفيرشوال ماشين يعمل على نظام وندوز المعرض للفيروسات والإنهيار فى بعض الأحيان.
لتحميل الملف الثالث عشر من
[size=32]هنا
ولتحميل الديب فريز الذى يعمل على وندوز إكس بى من
[size=32]هنا
[/size]ولتحميل الديب فريز الذى يعمل على وندوز سيرفر من
[size=32]هنا
[/size]
[/size]
[/size]

[size=24]*******************************
[/size]

[size=24]الجزء الخامس عشر: [size=18]شرح كيفية فصل التحميل عن التصفح [/size]
متنساش تحذف اى رول كوى ترى او اى رول خاصة بالهوت سبوت فى السمبل كوى
أو على الأقل استخدم ترتيب الرولات وخلى رول الهوت سبوت اخر رول

يعنى السمبل كوى لو لقيت فيه اى رول اسمها
يخص الهوت سبوت احذفها وسيب الرولات دى فقط
وللعلم تحديد السرعة بهذه الطريقة يتم تطبيقها على العميل حتى لو هوا
Bypassed

ولو عاوز تحدد على عميل عميل خد الكود دا بيطبق فى السمبل كوى بدلا من الكوى ترى
وانا افترضت ان اقصى سرعة تحميل اسمها Max_Download
وعملت تحديد سرعتها 1.5 ميجا بت
يعنى 1536 كيلوا بت
وافترضت ان العملاء عندك ايبيهاتتهم 192.168.100.x
فحطيت ليك اى بى رقمه 20.20.20.1 وسرعته فى التحميل256كيلوا بايت
انتا بقى غير الأى بى20.20.20.1 لأى بى من رينج الشبكة بتاعتك وجرب عليه
واى يوزر تانى ضيفه بنفس الطريقة بالملى الى انا ضايف بيها اليوزر
20.20.20.1
ومتنساش تختار
Parent =Max_Download
من التبويب
Advanced
وإليك الكود

[/size]
[size=18]لتحميل الكود الخاص بتحديد الدونلوود فقط من [size=32]هنا[/size][/size]
[size=18]لتحميل الكود الخاص بتحديد الدونلوود + الأبلود من [size=32]هنا
وتنويه مهم جدا
السرعات هنا تحدد مثل المعتاد عليها دائما
Byte= 8 Bit
64 KB = 512 kb
[/size][/size]


صورة توضيحية تبين كيفية تعديل السرعة الموجودة فى الكود المراد تشغيلها للدونلوود فى الخط لمن يريد تشغيل الطريقة
[size=18] [size=18]وهذه الصورة توضيحية لآخر سطر فى الكود وهو الذى يتم التعديل فيه
[/size][/size]


[size=18][/size]


[size=18]وعلى فكرة الطريقة شغالة حتى لو العميل
Bypassed
من الهوت سبوت ومش موجود أصلا فى Active
وعلى فكرة البنج مبيعلاش
يعنى تحديد سرعة دونلوود والبنج هادى وميات زى ماهو على جوجل
ليه لأن السيرفر الى العميل بيحمل منه الى اتحدد سرعته فقط الى هوا مثلا فى المثال جوا الشرح ميكروسوفت
لكن جوجل معملناش منه دونلوود فمفيش تحديد سرعة عليه فالبنج عليه ميات
time<=100 ms
[/size]
[size=32][size=16]تم التطبيق فى الشرح على النسخة 3.3
لسبب أنى قد استخدمت Layer7
فى تنفيذ الطريقة وليست طريقة المانجل العادية
لأن ال Layer7
أدق بكثير من المانجل فى البحث عن المحتوى

*****************************
[/size][/size]

[size=18]تنويه بسيط فقط
لعرض الفيديو فى أفضل جودة يرجى جعل مقاس شاشة عرض الكمبيوتر
800 * 600
ثم تكبير ملف الفيديو ملأ الشاشة وعند التطبيق الخروج من حالة ملأ الشاشة إلى الحالة العادية
وانا اضطريت اعمل مقاس الشاشة ساعة التسجيل 800 * 600 وأخلى دقة الألوان 16 بت بدلا من بت 32 نظرا لأن الملف الخارج من التسجيل امتداده avi
فبيشغل حجم كبير جدا فكنت عشان اقلل حجمه عملت كدة فبرجاء التماس العذر فى ذلك

*********************************
رجاء لاتبلخلوا على وعلى أهلى بالدعاء بظهر الغيب بكل خير
[/size]
[size=18]ومسموح لأى شخص ينقل الموضوع لأى منتدى آخر لتعم الفائدة
[/size]

[size=18]فقط فى آخر الموضوع يقول يدعوا لصاحب الموضوع وأهله بكل خير[/size]

[size=18]وياريت كل واحد عنده استفسار يسيب لينا هنا الملف الى بيستفسر عنه رقم كام والدقيقة رقم كام
[/size]

[size=18]لأن ماينفعش واحد يقول مثلا
هوا انتا عامل DHCP Server هنا كذ وكذا ليه
او عامل mac بتاع العميل فى الخانة الى اسمها كذا ليه
طبعا ميستناش منى انى الف فى 12 ملف و 7ساعات اشوف واقول ياترى هوا قصده على اى جزء بالظبط
[/size]

[size=18]فياريت الى بيستفسر عن حاجة يسيب لينا اسم الملف والدقيقة بالظبط الى فيها استفساره
[/size]
[size=18]ساعدونا إننا نساعدكم
وفى النهاية أتقدم بخالص الشكر والتقدير لكل من ساعدنى فى إنهاء مثل هذا الموضوع الكبير
وأتقدم بالشكر لكل من يريد مساعدة الخير للآخرين
[/size]


[size=18][size=48]الله المستعان وإليه المشتكى وهو من وراء القصد وهو يهدى السبيل[/size][/size]
[size=18][size=24]منقول للأمانة[/size][/size]
الرجوع الى أعلى الصفحة اذهب الى الأسفل
http://elkemaily.3rab.pro
 
الميكروتيك من الألف إلى الياء
استعرض الموضوع السابق استعرض الموضوع التالي الرجوع الى أعلى الصفحة 
صفحة 1 من اصل 1

صلاحيات هذا المنتدى:لاتستطيع الرد على المواضيع في هذا المنتدى
منتديات ناصر الكميلى :: منتدى الشبكات السلكية واللاسلكية-
انتقل الى: